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Download Procedures for the Auto Import Module 

This procedure would only be done if the Power*Suite has already been installed on your 
Computer. 
 

 
1.) Click on the Auto Import Module selection in the Executables portion of our downloads 

page www.powerlogger.com/gpage1.html 

2.) Click on the “Auto Import Module” verbiage. This will activate the download file 
AutoImport2016.exe. 

 

3.) Click on the Down Arrow beside the  button and click on Save As and then 
direct the file to a place you can run if from later on. 

 
4.) This will activate the download file AutoImport2016.exe. This could initiate another 

download warning. 

 

5.) Click on the  button. This will activate the View Downloads window. 
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6.) Click on the  button. This will activate the Install Shield setup followed by the 
Windows Install window and the Power*Suite Welcome Message Window. 
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Installation Procedures for the Auto Import Module 
1.) Install Shield setup should be activated by run command and the Windows Install window 

followed by the AutoImport_2016 Welcome Message Window Click on the  
button. 

 
2.) This will activate the Destination Folder window with C:\PowerSuite_2016 as the default 

folder. If the initial application for PowerSuite 2016 was installed to a different folder click on 

the  button. If the default folder is OK then click on the  
button. 

 

3.) This will activate the Ready to Install window. Click on the  button. 
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4.) Next the user will see the Installing Power*Suite window copying files, writing to the registry, 
creating desktop icons, creating start menu folder, ODBC components etc. An example of 
this window can be seen below. 

 

5.) Once the Update Installation is complete the Install Wizard Completed window shown 

below will be activated. Click on the  buttons for the Auto Import install. 

 

You will now have the new Automated Import Icon Power*Suite 2016 Utilities folder in the start 
menu along with a new Automated Import Icon on your desktop. 
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This module allows the user to automate the importing of Power*Suite export files from a 
designated import directory into the Power*Suite’s Access database. This scenario would benefit 
network Power*Suite users with numerous wells being drilled on a daily basis. 

204BOverview 
The export files would be transmitted to town via email or dial up modems. We would utilize either 
a batch file transfer or an augment proprietary feature to Microsoft Outlook program to detach 
these export files and copy them to a specific directory. The Auto Import utility would then monitor 
this directory for any new Power*Suite export files on a timer than can be initialized in the setup 
utility. 
When any new Power*Suite export files are detected the utility would automatically import these 
files into the database which would then update the existing well so that they can be viewed by 
the user(s). The successfully imported files would then be copied over into an “Old files” directory 
built by the utility and would be deleted within a specified time frame specified in the setup utility. 
If the files cannot be imported they are moved into a “Bad files” directory built by the utility. 
The setup utility can also handle 3 three different encryption passwords. These passwords would 
have to be predetermined between the field locations and town and would be utilized if the well 
being drilled were considered tight. The “Bad file” directory where the unsuccessfully imported 
files are directed to can either be password protected files with the wrong decryption password or 
they may be corrupted which could happen during a file transmission from a remote location. The 
user would manually have to delete these files. 

207BOperating Procedures 

1. Double click on the  desktop Icon if you have one. Skip to step 3. or 

2. In Windows 7 or less, to activate the Auto Import Utility click on the button on the 
toolbar and click on All Programs and select PowerSuite_2016. Then, select Utilities then 
Auto Import  Selection. In Windows 8 you can press the Windows key on the keypad and 
type Auto Import into the search bar and then select the Auto Import to activate the 
window. This will activate the Connect Database window shown below. 

 
Connecting to a Database… 
3. Highlight the database you wish to connect to by clicking on it. The default after loading 

the Power*Suite software is the PGEOLOGY 2016 METRIC (Microsoft Access Driver 
[*.mdb]). This will be the database which the Power*Suite export files will be automatically 
imported to. 

4. Type in your User ID. The default User ID is “pgeology*” and is displayed as the default in 
this field. The user can simply Tab to the Password field. 

5. Type in your Password. (The default Password is "pgeology"). 
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6. Click on the  button to complete the connection or press the Enter key on your 
keypad. This will activate the Automated Import Module shown below. 

 

 
 
1. The user must first stop the Automated import utility in order to setup the export files 

directory, passwords and other setup criteria. Click on the  Stop button on the toolbar or 
click on Stop from the Import menu selection. 

2. Click on the  Setup button on the toolbar or click on Setup from the Options menu 
selection. This will activate the Setup window shown below. 

 

 

This window allows the user to specify which directory the Auto Import Utility will be looking for 
Power*Suite Export files. How often the utilities will monitory the folder for export files. How many 
days the old export files will be kept in the “Old Files” directory as well as the default encryption 
passwords for which the utility will use to decrypt any encrypted files. 
 
3. In the Export File Directory Field the user must type in the path and directory name 

where the export files are being copied. This will indicated to the Utility where to monitor for 
Power*Suite export files. 

4. In the Import Interval Field the user must type in the time in minutes between checks on 
the folder specified in step 8. This will indicated how frequent the Utility monitors for 
Power*Suite export files in the export files folder. 

5. In the File History Field the user must type in the time in days that any successfully 
imported files will be kept in the old files folder before they are deleted. 

6. In the Password 1, 2 & 3 fields the user can type in any predetermined passwords (in 
Upper Case [CAPITAL LETTERS]) that will decrypt any encrypted Power*Suite export files. 
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7. Click on the  button. 

8. Click on the  Start button on the toolbar or click on the Import pull down menu 
selection and select Start. 

The User has now successfully setup the automated Import Utility and it will monitor the 
designated folder as frequently as specified until the user stops the import utility. 

File Menu 

Shrink Log History 

This selection allows the user to view a portion of the last page of the Autoimp. Log file so that 
any new action can be seen. 
 
To activate this click on Shrink Log History located under the File menu selection on the main 
Auto Import window. 
This will then truncate the file so that the last action is always in the middle of the log window. 

Print 

This selection allows the user to print the Auto Import log history to the default printer. 
To activate this click on Print located under the File menu selection on the main Auto Import 
window. 
This will then print the Auto Import Log. 

Print Preview 

This selection allows the user to print to a preview window the Auto Import log history. 
The user can then select print, View Next page, View Previous page, View One page, View Two 
pages, Zoom Out, Zoom In and Close from the toolbar on the top of this window. 
To activate this click on Print Preview located under the File menu selection on the main Auto 
Import window. 
This will then print to preview the Auto Import Log. 

Print Setup 

This selection allows the user to print to activate the Printer Setup window to select the desired 
printer and define the page setup etc. 
To activate this click on Print Setup located under the File menu selection on the main Auto 
Import window. 
This will then activate the Print Setup window which handles the Printer and the page / paper 
orientation etc. 

Exit 

This selection allows the user to close down or exit the Auto Import Module. 
To activate this click on Exit located under the File menu selection on the main Auto Import 
window. 
This will then close down the Auto Import Module. 

Edit Menu 

Undo 

This selection allows the user to undo anything that has been cut or pasted within the Auto Import 
Log history. 
To undo anything that has been cut out or pasted by the user they must click on Undo located 
under the Edit menu selection on the main Auto Import window. This will undo the last cut or 
paste that was done in the log history. 
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Cut 

This selection allows the user cut out a portion of the Auto Import Log history. 
 
1. The user must first highlight by clicking and dragging with the mouse a portion or all of the 

history. The highlighted portion of the log history will be cut if step two (2) is done. 
2. To cut out or erase the highlighted portion of the log history the user must click on Cut 

located under the Edit menu selection on the main Auto Import Window. The highlighted 
portion of the log will be cut and saved to the clipboard. 

Copy 

This selection allows the user copy a portion or all of the Auto Import Log history. 
 
1. The user must first highlight by clicking and dragging with the mouse a portion or all of the 

history. The highlighted portion of the log history will be copied if step two (2) is done. 
2. To copy the highlighted portion of the log history the user must click on Copy located under 

the Edit menu selection on the main Auto Import Window. The highlighted portion of the log 
will be copied and saved to the clipboard. 

Paste 

This selection allows the user to paste a previously cut or copied portion of the Auto Import Log 
history into the existing history log. 
 
1. The user must place the mouse where they wish to paste the copied or cut log history. The 

previously copied or cut log history will be pasted if step two (2) is done. 
2. The user must click on Paste located under the Edit menu selection on the main Auto Import 

Window. The previously cut or copied portion of the Auto Import log history that was saved to 
the clipboard will be pasted into the log. 

View Menu 

Tool Bar 

This selection allows the user to turn on or off the Tool bar on the Auto Import Window 
 

The user must click on Toolbar located under the View menu selection on the main window. 
This will turn either off or on the Toolbar depending on its status at the time of activation.  

Status Bar 

This selection allows the user to turn on or off the Status bar on the Auto Import Window. 
The user must click on Status located under the View menu selection on the main window. This 
will turn either off or on the Status bar depending on its status at the time of activation.  

Import Menu 

Start 

This selection allows the user to activate or start the Import Module detecting any new files in the 
Import files directory. 

 The user must select Start located under the Import selection on the main window or they 

can click on the  Start button on the toolbar. This will activate or start the Import 
Module detecting any new files in the Import files directory. The user will also notice a 
date and time stamp and the comment Start in the Log History. 

Stop 
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This selection allows the user to deactivate or stop the Import Module from detecting any new 
files in the Import files directory. 

 The user must select Stop located under the Import selection on the main window or they 

can click on the  Stop button on the toolbar. This will deactivate or stop the Import 
Module from detecting any new files in the Import files directory. The user will also notice 
a date and time stamp and the comment Stop in the Log History. 

Options Menu 

Setup 

This selection allows the user to specify which directory the Auto Import utility will be looking for 
the export files. How often the utility will look for the files. How many days the files will be kept in 
the ‘Old files’ directory as well as the default encryption passwords for which the utility will use to 
decrypt any encrypted files. 
1. The user must first stop the Automated import utility in order to setup the export files 

directory, passwords and other setup criteria. Click on the  Stop button on the toolbar 
or click on the Stop under the Import menu selection. 

2. The user must click on Setup located under the Options menu selection on the main 

window or they can click on the Setup button on the toolbar. This will activate the 
Setup window shown below: 

 
 
3. In the Export File Directory field the user can type in the path and folder name where the 

export files are being wrote to. This will indicate to the system where to monitor for export 
files. 

4. In the Import Interval field the user can type in the amount of time (in minutes) between 
checks on the directory specified in step 2. This will indicate to the utility how often to monitor 
the export file directory. 

5. In the File History field the user can type in the amount of time (in days) that any 
successfully imported files will be kept in the ‘Old files’ subdirectory before they are deleted. 

6. In the Password 1, 2 & 3 fields the user can type in any predetermined encryption 
passwords (in capitals) that would decrypt any encrypted files. 

7. Once any or all of the above fields have been modified the user must click on the  
button. 

Window Menu 

New Window 
Use this command to start a new Auto Import Log. 
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The user must click on New located under the Windows menu selection on the main window to 
arrange multiple log history windows in a cascading manner. 

Cascade 

Use this command to arrange multiple opened windows in a non-overlapping, top to bottom 
fashion. 
The user must click on Cascade located under the Windows menu selection on the main 
window to arrange multiple log history windows in a cascading manner. 

Tile 

Use this command to arrange multiple opened windows in a non-overlapping, side-by-side 
fashion. 
The user must click on Tile located under the Windows menu selection on the main window to 
arrange multiple log history windows in a tiled manner. 

Arrange Icons 

Use this command to arrange icons. 
The user must click on Arrange Icons located under the Windows menu selection on the main 
window to arrange your icons. 

Help Menu 

About Auto Import 
 

1. The user must click on About Auto Import located under the Help menu selection on the 
main window to activate the About window. 

 

 

2. Click on the  button to exit this window. Auto Import Module 
 
This module allows the user to automate the importing of Power*Suite export files from a 
designated import directory into the Power*Suite’s Access database. This scenario would benefit 
network Power*Suite users with numerous wells being drilled on a daily basis. 


