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Installation Procedures for PowerSuite along with the 
Automated Import Module 

1.) Insert Power*Suite CD V10 into the CD Rom Drive of your Computer. 

 
2.) If the Autorun works the CD ROM should be activated automatically and you will see the Window 

above. Select Install Power*Suite. If the CD does not Autorun move ahead to Step 4. 

 

3.) Click on Main Setup and proceed to step 6 

4.) Click on the  button on your task bar and then click on the Run selection. 
This will activate the Run window. 

 

5.) Click on the  button and select the setup.exe from the CDrom drive. Click on 

the  button in the Run window. 

6.) This will activate the Install Shield setup followed by the Windows Install window and the 

Power*Suite Welcome Message Window. Click on the  button. 
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7.) This will activate the License Agreement window. Click on the  beside I accept the terms in the 

license agreement. Then click on the  button. 

 
8.) This will activate the Customer Information window with User Name and Organization fields. In the 

Install this application for portion of the window Click on the  beside Anyone who uses this 

computer. Then click on the  button. 
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9.) This will activate the Destination Folder window with C:\POWERSUITE_V10 as the default location. 

Click on the  button. 

The User has the ability to change the destination folder if required by clicking on the 

 button. This is not recommended. 

 
10.) This will activate the Database Folder Location window with C:\POWERSUITE_V10\Database as 

the default location. Click on the  button. 

The user has the ability to change the database destination folder by clicking on the  
button. This is recommended if you are working with a LAN system where the Network directory is 
being backed up on a regular basis. If not the default destination folder is recommended. 

 
11.) This will activate the Setup for Hasp Window. If you have a Hasp USB or parallel port key and it 

has been activated for Power*Suite Version 10 Click on the  button. If you do not have 
a hasp key and you are evaluating then Uncheck the  and then Click on 

the  button 
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12.) This will activate the Setup Type window with PowerSuite as the default. To install the 
AutoImport module click on the down arrow beside the options you would like to install and select 

This feature will be installed on the local hard drive as shown below. Click on the  
button. 

     

13.) This will activate the Ready to Install window. Click on the  button. 

 
14.) Next the user will see the Installing Power*Suite window copying files, writing to the registry, creating 

desktop icons, creating start menu folder, ODBC components etc. An example of this window can be 
seen below. 

 

15.) This will activate the Hasp Device Driver Installation Welcome window. Click on the  
button. 
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16.) This will activate the End User License Agreement for the Hasp Driver. Click on the radio button  

beside I accept the license agreement. Then click on the  button. 

 
17.) This will initiate the install windows for the HASP device drivers. 
18.) When the installation is complete the program will activate the Finished window. Click on the 

 button 
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19.) This will activate the Power*Suite Update Welcome Message Window. Click on the  
button. 

 

20.) This will activate the License Agreement window. Click on the  button. 

 
21.) This will activate the Destination Folder window with C:\POWERSUITE_V10 as the default location. 

Click on the  button. 

The User has the ability to change the destination folder if required by clicking on the  
button. This all depends on where the original Power*Suite was installed. 
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22.)  This will activate the Custom Setup window with PowerSuite as the default. Click on the 

 button 

 

23.) This will activate the Ready to Install the Program window. Click on the  button. 
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24.) Next the user will see the Installing Power*Suite Update window copying files, removing backup files 
etc. An example of this window can be seen below. 

 
 

25.) Once the Update Installation is complete the Install Wizard Completed window shown below will be 

activated. Click on the  buttons twice for the Update and the Main install. 

     
 

You will now have successfully installed the Power*Suite Update to the PowerSuite V10 folder. 
 

You will now have the PowerSuite folder as well as the Automated Import Icon in the start menu along with 
the Power*Log, Power*Core, Power*Curve and the Automated Import Icons on your desktop. 
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Installation Procedures for the Auto Import Module 
This procedure would only be done if the Power*Suite has already been installed on your Computer. 
 

This procedure would only be done if the Power*Suite has already been installed on your Computer. 
 
19.) Insert Power*Suite CD V10 into the CD Rom Drive of your Computer. 

 
20.) If the Autorun works the CD ROM should be activated automatically and you will see the Window 

above. Select Install Power*Suite. If the CD does not Autorun move ahead to Step 4. 

 

21.) Click on Main Setup and proceed to step 6 

22.) Click on the  button on your task bar and then click on the Run selection. 
This will activate the Run window. 

 

23.) Click on the  button and select the setup.exe from the CDrom drive. Click on 

the  button in the Run window. 
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24.) This will activate the Install Shield setup followed by the Windows Install window and the 

Power*Suite Welcome Message Window. Click on the  button. 

 
25.) This will activate the Program Maintenance window with Modify as the default. If it is not, click on the 

 radio button and then click on the  button. 

 
26.) This will activate the Setup Type window with PowerSuite as the default. To install the 

AutoImport module click on the down arrow beside the options you would like to install and select 

This feature will be installed on the local hard drive as shown below. Click on the  
button. 
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27.) This will activate the Ready to Install window. Click on the  button. 

 
28.) Next the user will see the Installing Power*Suite window copying files, writing to the registry, creating 

desktop icons, creating start menu folder, ODBC components etc. An example of this window can be 
seen below. 

 

29.) This will activate the Hasp Device Driver Installation Welcome window. Click on the  
button. 

 

30.) This will then attempt to reinstall the HASP 4 device driver installation. Click on the  button. 

31.) This will activate an Install window. Click on the  button. 
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32.) This will then attempt to reinstall and the PowerSuite Patch. Click on the  button. 

 

33.) This will activate Verification to cancel the Update window. Click on the  button 

 
34.) Once the Update Installation is complete the Install Wizard Completed window shown below will be 

activated. Click on the  buttons twice for the Update and the Main install. 

     
 

You will now have the PowerSuite folder and a new Automated Import Icon in the start menu along with the 
Power*Log, Power*Core, Power*Curve and a new Automated Import Icon on your desktop. 
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Auto Import Module 
This module allows the user to automate the importing of Power*Suite export files from a designated import 
directory into the Power*Suite’s Access database. This scenario would benefit network Power*Suite users 
with numerous wells being drilled on a daily basis. 

Overview 
The export files would be transmitted to town via email or dial up modems. We would utilize either a batch 
file transfer or an augment proprietary feature to Microsoft Outlook program to detach these export files and 
copy them to a specific directory. The Auto Import utility would then monitor this directory for any new 
Power*Suite export files on a timer than can be initialized in the setup utility. 
When any new Power*Suite export files are detected the utility would automatically import these files into the 
database which would then update the existing well so that they can be viewed by the user(s). The 
successfully imported files would then be copied over into an “Old files” directory built by the utility and 
would be deleted within a specified time frame specified in the setup utility. 
If the files cannot be imported they are moved into a “Bad files” directory built by the utility. 
The setup utility can also handle 3 three different encryption passwords. These passwords would have to be 
predetermined between the field locations and town and would be utilized if the well being drilled were 
considered tight. The “Bad file” directory where the unsuccessfully imported files are directed to can either 
be password protected files with the wrong decryption password or they may be corrupted which could 
happen during a file transmission from a remote location. The user would manually have to delete these 
files. 
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Hasp Key License Activation 

 

1. To activate the Power*Suite License Selector click on the button on the taskbar 
and click on All Programs and select POWER*SUITE_V10. Then, select Utilities and click on 

the selection. This will activate the License Selector window. 
 

 
 

2. Click on the Options selection to view the pull down menu. 

 
3. Select HASP. The Protection type should read HASP Hardware Key as viewed in the Power*Suite 

License Selector window shown below. 
 

 
 

4. Click on the  button 

You are now ready to run either Power*Log, Power*Core, Power*Curve and the Automated Import Module 
depending on your Hasp Key and its authorization permissions. 
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Operating Procedures 

 

1. Click on the  button, select Programs, select POWER*SUITE_V10. Then, select 

Automated Import selection as shown above or double click on the  icon on the 
desktop. This will activate the Connect Database window shown below. 

 

 
 

Connecting to a Database… 
 
 

2. Highlight the database you wish to connect to by clicking on it. The default after loading the 
Power*Suite software is the pgeology V10 Metric (Microsoft Access Driver [*.mdb]). This will be 
the database which the Power*Suite export files will be automatically imported to. 

3. Type in your User ID. The default User ID is “pgeology*” and is displayed as the default in this 
field. The user can simply Tab to the Password field. 

4. Type in your Password. (The default Password is "pgeology"). 

5. Click on the  button to complete the connection or press the Enter key on your 
keypad. This will activate the Automated Import Module shown below. 
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Setup 
1. The user must first stop the Automated import utility in order to setup the export files directory, 

passwords and other setup criteria. Click on the  Stop button on the toolbar or click on Stop 
from the Import menu selection. 

2. Click on the  Setup button on the toolbar or click on Setup from the Options menu 
selection. This will activate the Setup window shown below. 

 

 

This window allows the user to specify which directory the Auto Import Utility will be looking for Power*Suite 
Export files. How often the utilities will monitory the folder for export files. How many days the old export files 
will be kept in the “Old Files” directory as well as the default encryption passwords for which the utility will 
use to decrypt any encrypted files. 
 

3. In the Export File Directory Field the user must type in the path and directory name where the 
export files are being copied. This will indicated to the Utility where to monitor for Power*Suite 
export files. 

4. In the Import Interval Field the user must type in the time in minutes between checks on the 
folder specified in step 8. This will indicated how frequent the Utility monitors for Power*Suite 
export files in the export files folder. 

5. In the File History Field the user must type in the time in days that any successfully imported 
files will be kept in the old files folder before they are deleted. 

6. In the Password 1, 2 & 3 fields the user can type in any predetermined passwords (in Upper 
Case [CAPITAL LETTERS]) that will decrypt any encrypted Power*Suite export files. 

7. Click on the  button. 

8. Click on the  Start button on the toolbar or click on the Import pull down menu selection and 
select Start. 

The User has now successfully setup the automated Import Utility and it will monitor the designated folder as 
frequently as specified until the user stops the import utility. 
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File Menu 
Shrink Log History 

This selection allows the user to view a portion of the last page of the Autoimp. Log file so that any new 
action can be seen. 
 
To activate this click on Shrink Log History located under the File menu selection on the main Auto 
Import window. 
This will then truncate the file so that the last action is always in the middle of the log window. 

Print 

This selection allows the user to print the Auto Import log history to the default printer. 
To activate this click on Print located under the File menu selection on the main Auto Import window. 
This will then print the Auto Import Log. 

Print Preview 

This selection allows the user to print to a preview window the Auto Import log history. 
The user can then select print, View Next page, View Previous page, View One page, View Two pages, 
Zoom Out, Zoom In and Close from the toolbar on the top of this window. 
To activate this click on Print Preview located under the File menu selection on the main Auto Import 
window. 
This will then print to preview the Auto Import Log. 

Print Setup 

This selection allows the user to print to activate the Printer Setup window to select the desired printer and 
define the page setup etc. 
To activate this click on Print Setup located under the File menu selection on the main Auto Import 
window. 
This will then activate the Print Setup window which handles the Printer and the page / paper orientation etc. 

Exit 

This selection allows the user to close down or exit the Auto Import Module. 
To activate this click on Exit located under the File menu selection on the main Auto Import window. 
This will then close down the Auto Import Module. 

Edit Menu 
Undo 

This selection allows the user to undo anything that has been cut or pasted within the Auto Import Log 
history. 
To undo anything that has been cut out or pasted by the user they must click on Undo located under the 
Edit menu selection on the main Auto Import window. This will undo the last cut or paste that was done in 
the log history. 

Cut 

This selection allows the user cut out a portion of the Auto Import Log history. 
 

1. The user must first highlight by clicking and dragging with the mouse a portion or all of the history. 
The highlighted portion of the log history will be cut if step two (2) is done. 

2. To cut out or erase the highlighted portion of the log history the user must click on Cut located 
under the Edit menu selection on the main Auto Import Window. The highlighted portion of the log 
will be cut and saved to the clipboard. 

Copy 

This selection allows the user copy a portion or all of the Auto Import Log history. 
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1. The user must first highlight by clicking and dragging with the mouse a portion or all of the history. 
The highlighted portion of the log history will be copied if step two (2) is done. 

2. To copy the highlighted portion of the log history the user must click on Copy located under the 
Edit menu selection on the main Auto Import Window. The highlighted portion of the log will be 
copied and saved to the clipboard. 

Paste 

This selection allows the user to paste a previously cut or copied portion of the Auto Import Log history into 
the existing history log. 
 

1. The user must place the mouse where they wish to paste the copied or cut log history. The 
previously copied or cut log history will be pasted if step two (2) is done. 

2. The user must click on Paste located under the Edit menu selection on the main Auto Import 
Window. The previously cut or copied portion of the Auto Import log history that was saved to the 
clipboard will be pasted into the log. 

View Menu 
Tool Bar 

This selection allows the user to turn on or off the Tool bar on the Auto Import Window 
 

The user must click on Toolbar located under the View menu selection on the main window. This will turn 
either off or on the Toolbar depending on its status at the time of activation.  

Status Bar 

This selection allows the user to turn on or off the Status bar on the Auto Import Window. 
The user must click on Status located under the View menu selection on the main window. This will turn 
either off or on the Status bar depending on its status at the time of activation.  

Import Menu 
Start 

This selection allows the user to activate or start the Import Module detecting any new files in the Import files 
directory. 

• The user must select Start located under the Import selection on the main window or they can click 

on the  Start button on the toolbar. This will activate or start the Import Module detecting any 
new files in the Import files directory. The user will also notice a date and time stamp and the 
comment Start in the Log History. 

Stop 

This selection allows the user to deactivate or stop the Import Module from detecting any new files in the 
Import files directory. 

• The user must select Stop located under the Import selection on the main window or they can click 

on the  Stop button on the toolbar. This will deactivate or stop the Import Module from 
detecting any new files in the Import files directory. The user will also notice a date and time stamp 
and the comment Stop in the Log History. 

Options Menu 
Setup 

This selection allows the user to specify which directory the Auto Import utility will be looking for the export 
files. How often the utility will look for the files. How many days the files will be kept in the ‘Old files’ directory 
as well as the default encryption passwords for which the utility will use to decrypt any encrypted files. 
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1. The user must first stop the Automated import utility in order to setup the export files directory, 

passwords and other setup criteria. Click on the  Stop button on the toolbar or click on the 
Stop under the Import menu selection. 

2. The user must click on Setup located under the Options menu selection on the main window or 

they can click on the Setup button on the toolbar. This will activate the Setup window shown 
below: 

 
 

3. In the Export File Directory field the user can type in the path and folder name where the 
export files are being wrote to. This will indicate to the system where to monitor for export files. 

4. In the Import Interval field the user can type in the amount of time (in minutes) between checks 
on the directory specified in step 2. This will indicate to the utility how often to monitor the export file 
directory. 

5. In the File History field the user can type in the amount of time (in days) that any successfully 
imported files will be kept in the ‘Old files’ subdirectory before they are deleted. 

6. In the Password 1, 2 & 3 fields the user can type in any predetermined encryption passwords 
(in capitals) that would decrypt any encrypted files. 

7. Once any or all of the above fields have been modified the user must click on the  
button. 

Window Menu 
New Window 
Use this command to start a new Auto Import Log. 
The user must click on New located under the Windows menu selection on the main window to arrange 
multiple log history windows in a cascading manner. 

Cascade 

Use this command to arrange multiple opened windows in a non-overlapping, top to bottom fashion. 
The user must click on Cascade located under the Windows menu selection on the main window to 
arrange multiple log history windows in a cascading manner. 

Tile 

Use this command to arrange multiple opened windows in a non-overlapping, side-by-side fashion. 
The user must click on Tile located under the Windows menu selection on the main window to arrange 
multiple log history windows in a tiled manner. 

Arrange Icons 

Use this command to arrange icons. 
The user must click on Arrange Icons located under the Windows menu selection on the main window to 
arrange your icons. 

Help Menu 
About Auto Import 
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1. The user must click on About Auto Import located under the Help menu selection on the main 

window to activate the About window. 
 

 

2. Click on the  button to exit this window. 
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